AP注册方式

 

有两种注册方式:AC发现AP、AP发现AC

AC发现AP两种模式:二层发现模式、三层发现模式

AP发现AC两种方式:AP上静态指定AC列表、AP通过DHCP方式获取AC列表(利用option 43项)

// 项目实施时建议采用AC二层发现AP方式(AC、AP二层连通)或者利用DHCP option 43 方式让AP发现AC(AC、AP三层连通)//

AP注册报文

报文类型 协议类型 协议端口号 举例
管理报文 UDP 57776 自动发现报文、AP注册报文等
TCP 57777 KeepaliveAP配置下发等(加密)
集中式隧道报文 UDP Sport57778

Dport57779

集中转发时所有用户数据报文

无论何种注册方式,必须保证AC管理地址与AP地址之间必须互通!!!!

AC二层发现AP

基本原理:AC上面可以指定二层自动发现的vlan列表,向列表中的各个vlan发送自动发现报文。收到广播发现报文的AP会向AC做出响应。

注意:只有AC发出的Discovery报文是广播的,后续AC-AP间交互的报文均是单播(udp)。

以下为二层发现拓扑

AC配置

service dhcp /使用DHCP服务下发ip给AP/
!
ip dhcp pool vlan100
 network-address 192.168.100.0 255.255.255.0
 default-router 192.168.100.254
!
vlan 1;100 
!
Interface Ethernet1/0/1
 switchport mode trunk
!
interface Vlan100
 ip address 192.168.100.254 255.255.255.0
!
!
no login
wireless
 no auto-ip-assign
 enable
 no discovery vlan-list 1 /关闭默认vlan列表/
 discovery vlan-list 100 /此vlan列表一般和AP接口vlan-id一样,默认vlan列表为vlan1/
 static-ip 192.168.100.254 /管理地址/

AP配置

DCN-WLAN-AP# set management vlan-id 100 /修改AP接口vlan-id,默认为vlan 1/
DCN-WLAN-AP# get management detail  
Property Value
---------------------------------------------
vlan-id 100
interface brvlan100
static-ip 192.168.1.10 /ap默认地址/
static-mask 255.255.255.0 
ip 192.168.100.1 /DHCP下发的地址/
mask 255.255.255.0

查看AC发现vlan列表

DCWS#show wireless discovery vlan-list
  VLAN Name
---------------------------
  100 VLAN0100

查看无线是否开启

DCWS#show wireless
Administrative Mode............................ Enable
Operational Status............................. Enabled

查看是否注册

DCWS#show wireless ap failure status /如果什么都没有,证明注册失败,请检查配置是否正确/
   MAC Address 
 (*) Peer Managed IP Address Last Failure Type Age 
------------------ ---------------------------------------------
 00-03-0f-30-a1-60 192.168.100.1 No Database Entry 0d:00:00:05

如果想使用AP无配置上线,AP为默认配置,AC接口配置本征vlan为100,vlan列表为默认vlan 1即可

AC三层发现AP 

基本原理:AC上面配置三层发现IP地址列表,AC根据列表中的地址发送单播包发现AP。

以下为三层发现&AP发现AC拓扑

SW2主要配置命令

service dhcp      /使用DHCP下发地址给AP/
!
ip dhcp pool vlan100
 network-address 100.1.1.0 255.255.255.0
 lease 45 0 0 
 default-router 100.1.1.254
!
vlan 1;100 
!
Interface Ethernet1/0/1
 switchport mode trunk
 switchport trunk native vlan 100

路由器的配置略过,保证全网互通即可

查看AC路由表&接口信息&测试能否ping通

DCWS(config)#show ip route 
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
 O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default
O 10.1.1.0/30 [110/3] via 30.1.1.1, Vlan233, 00:03:02 tag:0
O 20.1.1.0/30 [110/2] via 30.1.1.1, Vlan233, 00:03:02 tag:0
C 30.1.1.0/30 is directly connected, Vlan233 tag:0
O 100.1.1.0/24 [110/4] via 30.1.1.1, Vlan233, 00:03:02 tag:0 /已有AP网段路由/
C 127.0.0.0/8 is directly connected, Loopback tag:0
Total routes are : 5 item(s)

DCWS(config)#show ip interface brief
Index Interface IP-Address Protocol
11001 Vlan1 192.168.1.1 down
11233 Vlan233 30.1.1.2 up /此地址作为管理地址/
17500 Loopback 127.0.0.1 up

DCWS#ping 100.1.1.1 
Type ^c to abort.
Sending 5 56-byte ICMP Echos to 100.1.1.1, timeout is 2 seconds.
!!!!! /能互通/
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

AC无线配置

wireless
 no auto-ip-assign
 enable
 discovery ip-list 100.1.1.1
 static-ip 30.1.1.2

查看AC三层发现列表

DCWS#show wireless discovery ip-list
Maximum Number of Configurable Entries......... 256
Total Number of Configured Entries............. 1
Total Number of Polled Entries................. 1
Total Number of Not-Polled Entries............. 0
Total Number of Discovered Entries............. 0
Total Number of Discovered-Failed Entries...... 0
IP Address Status 
-----------------------
100.1.1.1 Polled

查看是否注册

DCWS#show wireless ap failure status
    MAC Address 
 (*) Peer Managed IP Address Last Failure Type Age 
------------------ ---------------------------------------------
 00-03-0f-30-a1-60 100.1.1.1 No Database Entry 0d:00:00:04

AP通过DHCP option 43项方式获取AC列表

AP通过DHCP 中的Option43选项获取AC地址

SW2配置(以上配置继续使用)

ip dhcp pool vlan100
 option 43 hex 01041E010102 /此为16进制地址,0104为DCN固定前缀1E010102为30.1.1.2/

AC配置

wireless
 no enable
 no discovery ip-list 100.1.1.1
 enable

查看AP上获取的option43中的地址(AC地址)

DCN-WLAN-AP# get managed-ap 
Property Value
--------------------------------------
mode up
managed-type 0
ap-state down
switch-address-1 
switch-address-2 
switch-address-3 
switch-address-4 
switch-ipv6-address-1 
switch-ipv6-address-2 
switch-ipv6-address-3 
switch-ipv6-address-4 
dhcp-switch-address-1 30.1.1.2 /从DHCP获取的option43地址/

如果不能注册,请重启一下AP和SW2

AP静态发现AC 

AP配置 (以上配置继续使用)

DCN-WLAN-AP# set managed-ap switch-address-1 30.1.1.2
DCN-WLAN-AP# get managed-ap  /查看配置的静态AC地址/
Property Value
--------------------------------------
mode up
managed-type 0
ap-state down
switch-address-1 30.1.1.2

SW2配置

ip dhcp pool vlan100
 no option 43

AC配置

wireless
 no enable
 enable

如果无法注册请重启AC、SW2、AP


0 条评论

发表评论

邮箱地址不会被公开。 必填项已用*标注